App Requirements:

iOS: Requires iOS 14.0 or later.

Compatible with iPhone 6s or later, iPad, and iPod touch.

Android: Requires Android 8.0 or later.